Install Hpricot on Ubuntu

5 June 2009

It’s quite easy. Make sure you have RubyGems and Ruby installed first, of course.

The problem:

$ sudo gem install hpricot
Building native extensions.  This could take a while...
ERROR:  Error installing hpricot:
    ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
    from extconf.rb:1

The solution:

sudo apt-get install ruby1.8-dev build-essential
sudo gem install hpricot